红旗linux桌面版V11安装最新版libreoffice24.2打开时出错
中和 1月前 333

红旗linux桌面版V11安装最新版libreoffice24.2打开时出错(安装包名称:

LibreOffice_24.2.0.3_Linux_x86-64_deb,系统是64位的inter芯片,戴尔笔记本)

直接用鼠标点击打开时出现libreoffice快速展示后就没有反应了。用命令行打开时(命令为libreoffice24.2 --calc)的出错信息如下:

/opt/libreoffice24.2/program/soffice.bin: relocation error: /opt/libreoffice
ymbol _ZNK7QWidget6screenEv version Qt_5 not defined in file libQt5Widgets.s

不懂英文,有遇到这种情况的吗?

最新回复 (2)
  • 0 2
    看起来是需要升级libqt5widgets5这个包
    1月前 回复
  • 中和
    0 3
    apt show libqt5widgets5的结果是:“
    Package: libqt5widgets5
    Version: 5.11.3+dfsg1-1+deb10u5
    Priority: optional
    Section: libs
    Source: qtbase-opensource-src
    Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
    Installed-Size: 7,274 kB
    Depends: libc6 (>= 2.14), libqt5core5a (>= 5.11.0~rc1), libqt5gui5 (>= 5.11.0~rc1), libstdc++6 (>= 5), qtbase-abi-5-11-3
    Homepage: http://qt-project.org/
    Tag: role::shared-lib
    Download-Size: 2,261 kB
    APT-Manual-Installed: yes
    APT-Sources: https://mirrors.bfsu.edu.cn/debian buster/main amd64 Packages
    Description: Qt 5 widgets 模块
     Qt 是一个跨平台 C++ 应用程序框架。Qt 的主要特点在于其具有一个丰富的组件集,
     可以提供标准的图形界面功能。
     QtWidgets 模块使用 C++ widget 功能扩展了 QtGui 模块。”

    这说明系统提供的qt版本是5.11,这个可以自己升级吗?
    1月前 回复
返回